Issue about CMAQv5.3.2 simulation

Dear all,
Recently I met the following issue reported by my CMAQv5.3.2 run for the California domain and I have no clues about this as the error even didn’t directly show which file was incorrect. As indicated by Liz Adams in another post, it is suggested that trying to compile the CMAQ with traceback while I don’t know how to do this. Could you please further clarify how to compile CMAQ with traceback? I really want to fix this issue as soon as possible!
Error message:
forrtl: severe (27): too many records in I/O statement, unit -5, file Internal Formatted Write
Image PC Routine Line Source
CCTM_v532.exe 00000000008C1DDC Unknown Unknown Unknown
CCTM_v532.exe 000000000091093B Unknown Unknown Unknown
CCTM_v532.exe 00000000005E17C6 Unknown Unknown Unknown
CCTM_v532.exe 00000000005D579B Unknown Unknown Unknown
CCTM_v532.exe 00000000005E5F48 Unknown Unknown Unknown
CCTM_v532.exe 00000000006599D7 Unknown Unknown Unknown
CCTM_v532.exe 00000000005F1E21 Unknown Unknown Unknown
CCTM_v532.exe 00000000005EBE10 Unknown Unknown Unknown
CCTM_v532.exe 00000000005EA76A Unknown Unknown Unknown
CCTM_v532.exe 000000000040635E Unknown Unknown Unknown 000000375C61ED5D __libc_start_main Unknown Unknown
CCTM_v532.exe 0000000000406269 Unknown Unknown Unknown

Go to your BLD directory, edit the Makefile, and add either -traceback (for Intel or PGI compilers) or -fbacktrace (for GNU compilers) to the compile flags, then do make clean; make

Alternatively, you can also edit bldit_cctm.csh to uncomment #set Debug_CCTM which then enables multiple compiler-specific debug flags (including traceback) as defined in config_cmaq.csh.

If you have an existing BLD directory, the safest approach is probably to remove it first before re-running bldit_cctm.csh with the Debug_CCTM option enabled, or to modify the line set Bld = $CMAQ_HOME/CCTM/scripts/BLD_CCTM_${VRSN}_${compilerString} in bldit_cctm.csh to create a fresh BLD directory, maybe by adding ‘_debug’ after ‘${compilerString}’. If you do the latter, of course you’ll also have to update the CCTM run script to point to the executable in this new BLD directory.

And perhaps the simplest approach, not involving any file editing, would be this one documented in chapter 5 of the users guide:

cd BLD_CCTM_v53_[compiler][version]
make clean

This option is also documented in the header portion of the Makefile created by bldit_cctm.csh, regardless of the setting of Debug_CCTM in bldit_cctm.csh:

#   Command-Line Options:
#      DEBUG = TRUE or true -- turn on debug flags
#  OR  debug = true or TRUE -- turn on debug flags
#  Can set either variable by using the setenv command for
#  a debugging session with multiple compilations

Thanks! I will try that right now!

Hi Christian,
Thanks for your note. I always use the actual path for the CCTM.exe thus this might not be the primary cause. I just find something with my MEGAN output which I converted to SAPRC07 mechanism and am working for get this fixed.
Thanks again!