MCIP changing mercator to equatorial mercator


I’m using mcip 5.1 with wrfout files in a mercator projection. Everything runs ok, but when I check the mcip output file headers the projection is set to equatorial mercator, and the true lat. has been changed to zero.

The code below is from setgriddefs.f90

! The map projection types in I/O API are:
! 1: LATGRD for lat-lon coordinates
! 2: LAMGRD for Lambert coordinates
! 3: MERGRD for Mercator coordinates
! 4: STEGRD for Stereographic coordinates
! 5: UTMGRD for UTM coordinates
! 6: POLGRD for polar stereographic coordinates
! 7: EQMGRD for equatorial Mercator coordinates
! 8: TRMGRD for transverse Mercator coordinates
! 9: ALBGRD for Albers equal-area conic
! 10: LEQGRD for Lambert azimuthal equal-area

IF ( met_mapproj == 1 ) THEN ! Lambert conformal
gdtyp_gd = lamgrd3
ELSE IF ( met_mapproj == 2 ) THEN ! polar stereographic
gdtyp_gd = polgrd3
ELSE IF ( met_mapproj == 3 ) THEN ! equatorial Mercator
gdtyp_gd = eqmgrd3
WRITE (*,f9275) TRIM(pname), met_mapproj
CALL graceful_stop (pname)

The IF section seems at odds with the grid type definitions above. Has this been set deliberately for mcip to only output equatorial mercator rather that standard mercator projections, or is this an error in the code?

Many thanks for any help,

MERGRD is GIS-speak “general Mercator” – find a (possibly tilted) tangent cylinder at some arbitrary angle PROJ_GAMMA from the polar (N-S) axis, and use that for the projection. Rarely used.

EQMGRD3 is what WRF means by Mercator: for the projection, use a secant or tangent cylinder centered on the polar axis for the projection.

Thanks for the speedy reply,

I believe that’s what I’ve done, using a mercator projection in WRF with a true latitude of 6 degrees north.

Do you mean I should re-run WRF with a true latitude of zero?

No. Equatorial Mercator projections frequently do have a non-zero true latitude; just use the true latitude that WRF uses (and doing everything else, you’d have to start your WRF modeling – landuse and all – from scratch; you don’t want that!)

MCIP should do that automatically.

OK thanks, is there any way I can set the latitude in the run script to stop MCIP setting it to zero, or should I set it here and recompile? From setup_wrfem.f90 line 490 - 496,

CASE (3)  ! Mercator
  met_p_alp_d  = 0.0                      ! lat of coord origin [deg]
  met_p_bet_d  = 0.0                      ! (not used)
  met_p_gam_d  = met_proj_clon            ! lon of coord origin [deg]
  met_cone_fac = 0.0                      ! cone factor
  met_ref_lat  = -999.0                   ! not used