MCIP error when processing WRF V4.0.3 output

Dear all,

I am having trouble to run MCIP v4.5 with WRF V4.0.3. because the model in complaining about the WRF version. This is the error:

*** SUBROUTINE: SETUP
***   UNKNOWN OR UNSUPPORTED WRF OUTPUT VERSION
***   VERSION =  OUTPUT FROM WRF V4.0.3 MODEL

I changed the MCIP code at /src/setup.f90 and /src/setup_wrfem.f90 to also accept the V4 version:

in /src/setup.f90 at line 131
from:
IF (wrfversion(18:19) == "V3" ) THEN
to:
IF ( (wrfversion(18:19) == "V3") .OR. (wrfversion(18:19) == "V4") ) THEN

in /src/setup_wrfem.f90 at line 918
from:
IF ( (wrfversion(18:21) == "V2.2") .OR. (wrfversion(18:19) >= "V3") ) THEN

to:
IF ( (wrfversion(18:21) == “V2.2”) .OR. (wrfversion(18:19) >= “V3”) &
.OR. (wrfversion(18:19) >= “V4”)) THEN

My question is, if I make this changes, MCIP will keep its consistency or I will problems?
My WRF V4.0.3 is with terrain following sigma levels and not with hybrid vertical levels.

Here is the link to the github issue that I opened

Thank you so much for your help

1 Like

As long as you are not using the hybrid vertical coordinate in WRF (that is, the hybrid option is set to “0”), then I think you will be fine. MCIP is not yet set up to handle the hybrid vertical coordinate. The next release of MCIP (which will accompany CMAQv5.3) will support WRFv4.0+ and the hybrid vertical coordinate.

Tanya Spero,

Thank you for your reply and explanation.

Regards

Hello @rpedruzzi @tlspero @cjcoats @lizadams @bbaek
I have made the changes suggested by @rpedruzzi but the error still persists. What do I do next, please? Kindly help. Thanks.

Catalyst