Running CCTM in CMAQ failed

Hello, I just started to learn to run CMAQ, I use CMAQv5.3.3, where mcip file is run out by run_mcip.csh, emission file is given by the teacher, initial boundary file is processed by mozart2camx_v3.2.1, these three steps did not report errors, but there are problems when running cctm.

This is my environment:

Since there are many run scripts in CCTM, I ran one of them randomly.

See the I/O API “Troubleshooting” page, you have an executable compiled from a different machine architecture that you’re running on.

I read the content below the link but still can’t find a solution. Do you mean my I/O API needs to be updated or something else? Also, confusing, I ran cctm with CMAQv5.3.3 or CMAQ5.4 with this problem, but not with CMAQv5.2.1, but with version 5.2.1 I ran other problems, as follows:

Here are the last lines of the log file:
Value for CTM_PROCAN: N returning FALSE
PA_DATAGEN: Process Analysis is not activated
application called MPI_Abort(MPI_COMM_WORLD, 538976288) - process 15
Mon Jan 22 22:04:01 CST 2024
if ( ! -e /data/home/pzy/CMAQ5.4/CMAQ-5.2.1/data/output_CCTM_v52_intel_160702/LOGS ) then
mv CTM_LOG_001.v52_intel_160702_20230701 CTM_LOG_002.v52_intel_160702_20230701 CTM_LOG_003.v52_intel_160702_20230701 CTM_LOG_004.v52_intel_160702_20230701 CTM_LOG_005.v52_intel_160702_20230701 CTM_LOG_006.v52_intel_160702_20230701 CTM_LOG_007.v52_intel_160702_20230701 CTM_LOG_008.v52_intel_160702_20230701 CTM_LOG_009.v52_intel_160702_20230701 CTM_LOG_010.v52_intel_160702_20230701 CTM_LOG_011.v52_intel_160702_20230701 CTM_LOG_012.v52_intel_160702_20230701 CTM_LOG_013.v52_intel_160702_20230701 CTM_LOG_014.v52_intel_160702_20230701 CTM_LOG_015.v52_intel_160702_20230701 /data/home/pzy/CMAQ5.4/CMAQ-5.2.1/data/output_CCTM_v52_intel_160702/LOGS
setenv NEW_START false
set TODAYG = date -ud "${TODAYG}+1days" +%Y-%m-%d
date -ud 2023-07-01+1days +%Y-%m-%d
set TODAYJ = date -ud "${TODAYG}" +%Y%j
date -ud 2023-07-02 +%Y%j
while ( 2023183 < = 2023182 )

It means that someone built your CCTM on some other machine that isn’t fully hardware-compatible with the machine you’re using. You need to re-build the whole thing (starting with the netCDF and I/O API libraries) yourself. On the machine you’re using to run the CCTM.

1 Like