Running CMAQ 5.2.1 without aerosol species

Hi there,

I am trying to run a case with only biogenic emissions using CMAQ5.2.1.

We generate biogenic emissions using MEGAN3.0, which include many gas-phase species, but no aerosol species.

This seems to be a problem, because I get the error shown below.

     Value for CTM_ZERO_PCSOA not defined;returning default:   FALSE
     
     >>--->> WARNING in subroutine AERO_EMIS_INIT on PE 014
     Cannot define index for SO4 emissions: aerospc%emis=' ' in AERO_DATA.F. Check if AE namelist is
     M3WARN:  DTBUF 8:00:00   April 26, 2018(2018116:080000)
     
     >>--->> WARNING in subroutine AERO_EMIS_INIT on PE 014
     FATAL: Units incorrect on EMIS_1           for aerosol species.
     M3WARN:  DTBUF 8:00:00   April 26, 2018(2018116:080000)


     *** ERROR ABORT in subroutine EMIS_INIT on PE 014       
     Failure initializing aerosol emissions module
 PM3EXIT:  DTBUF 8:00:00   April 26, 2018
     Date and time 8:00:00   April 26, 2018 (2018116:080000)

Is it possible to run CMAQ 5.2.1 without aerosol species? I have set the flag “setenv CTM_EMISCHK F” to bypass the check in the emissions.

Thanks,

Marc

Hi Marc,
It is possible to run CMAQv5.2.1 without aerosol emissions. These aerosol species are needed by CMAQ but they can be 0 in your case. I mean, you should include these aerosol species in your emission file (which will avoid the error message raised by CMAQ) while the emission rate of these aerosol species can be set to 0 in the emission file.
If you need any script to do this, I would be happy to share my script to you.

With regards,
Kai

1 Like

Hi Kai,

Thanks for your reply. As you suggested, I ended up generating emission files with those aerosol species set to zero, and it works fine.
It’s a bit of a waste having to have duplicated files, with additional zero values, but we can live with that :smiley:

Thanks,

Marc

Hi Marc,
Glad to hear it works!

Best,
Kai

Thanks for this discussion Kai and Marc,

An alternative approach for CMAQv5.2.1 would be to use the AE namelist to set the Emissions Surrogates to some arbitrary variable (ASO4 maybe?) and then set EMIS_FAC to 0.0 for all aerosol species, or at least all of the species that have emissions on any file. This approach would avoid having to create and store duplicate files.

In CMAQv5.3 and beyond it is easier to turn off all aerosol emissions using the DESID emission control interface.

One complexity to be aware of in either case is that CMAQ automatically assumes that SULF emissions map to ASO4. In v5.2.1, this done in AERO_EMIS.F in two places, lines 877-881 and lines 1019-1022. CMAQ/AERO_EMIS.F at 5.2.1 · USEPA/CMAQ · GitHub

Best wishes,
Ben

1 Like

Hi Ben,

Thanks so much for your insights.

My issue was not that I had to zero out aerosol emissions in my emissions file. The problem was that my emission files did not have any aerosol species. I was trying to run a biogenics only case, so I was using as the emissions input the emissions file generated with MEGAN, which only had gas-phase species. But it seems that CMAQ requires aerosol species to be in the emissions file (or is this true for some specific aerosol species, like ASO4?)

I tried changing the AE namelist, trying to set all the aerosol species with no emissions surrogate, but that didn’t work either. It gave me the exact same error.

So does CMAQ require to have aerosol species in the emission files regardless of whether emissions are zero then?

Here is just the first few lines of the AE namelist that I modified:

! RCS file, release, date & time of last delta, author, state, [and locker]
! $Header: /project/yoj/arc/MECHS/src/cb05tucl_ae6_aq/AE_cb05tucl_ae6_aq.nml,v 1.2 2011/04/26 17:34:29 sjr Exp $

&AE_nml
 
n_surr1 = 4,
n_surr2 = 1,
n_ctrl = 4,
 
TYPE_HEADER =
'SPC:MOLWT:EMIS_SUR:EMIS_FAC:DEPV_SUR:DEPV_FAC:SCAV_SUR:SCAV_FAC:ICBC_SUR:ICBC_FAC:A2AQ_SUR:TRNS:DDEP:WDEP:CONC',
TYPE_MATRIX =
'ASO4J:96:::VMASSJ:1:SO4_ACCUM:1:::SO4_ACCUM:Yes:Yes:Yes:Yes',
'ASO4I:96:::VMASSI:1:SO4_AITKEN:1:::SO4_AITKEN:Yes:Yes:Yes:Yes',
'ANH4J:18:::VMASSJ:1:NH4_ACCUM:1:::NH4_ACCUM:Yes:Yes:Yes:Yes',
'ANH4I:18:::VMASSI:1:NH4_AITKEN:1:::NH4_AITKEN:Yes:Yes:Yes:Yes',
'ANO3J:62:::VMASSJ:1:NO3_ACCUM:1:::NO3_ACCUM:Yes:Yes:Yes:Yes',
'ANO3I:62:::VMASSI:1:NO3_AITKEN:1:::NO3_AITKEN:Yes:Yes:Yes:Yes',

Marc

Hi Marc,

I have successfully mapped aerosols to gas species in the past. For example, you could try mapping the aerosols to ‘CO’ (if you have it) and setting the scale factor to 0. This might allow CMAQ to find an existing species and also make it 0. I haven’t tried it for wholesale bypassing aerosol emissions before but it might work.

One additional issue might be the calculation of aerosol number and surface area emissions based on zero aerosol mass. The conversion to number and surface should be linear, so I don’t think it will cause a problem, but it’s something to be aware of.

Cheers,
Ben