Segmentation fault running met4moves


I had the following error message running met4moves for a 642 rows, 772 cols grid:

 File name "/fs/site2/dev/eccc/aq/r1/juz001/Zhuanshi/my.GEM-MACH_Output/test/daily/METCOMBO_180106.nc6"
 File type GRDDED3
 Execution ID "????????????????"
 Grid name "YY_NewReg10"
 Dimensions: 642 rows, 772 cols, 1 lays, 3 vbles
 NetCDF ID:         6  opened as READONLY
 Starting date and time  2018006:000000 (0:00:00   Jan. 6, 2018)
 Timestep                          010000 (1:00:00 hh:mm:ss)
 Maximum current record number        25
 Closing file METFILE

forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
met4moves 000000000054D121 Unknown Unknown Unknown
met4moves 000000000054B877 Unknown Unknown Unknown
met4moves 0000000000505E04 Unknown Unknown Unknown
met4moves 0000000000505C16 Unknown Unknown Unknown
met4moves 00000000004C698F Unknown Unknown Unknown
met4moves 00000000004CA3AD Unknown Unknown Unknown 00002B27B5ACF890 Unknown Unknown Unknown
met4moves 000000000055A8A5 Unknown Unknown Unknown
met4moves 000000000043CCCA setenvvar_ 804 envgets.c
met4moves 0000000000404DC7 MAIN__ 594 met4moves.f
met4moves 000000000040334E Unknown Unknown Unknown 00002B27B5F01B97 Unknown Unknown Unknown
met4moves 0000000000403259 Unknown Unknown Unknown
free(): invalid pointer
Abort (core dumped)

Could you please advise how to solve this problem?

Many thanks,


Junhua, the size of 642 rows and 772 columns domain seems pretty big. Have you tried to increase the RAM memory usage for Met4moves run? How much memory has been allocated for this run?

Thank you very much BH for the quick response! We tried 64G memory, but still has the same problem.

This (routine SETENVVAR() at line 804 in envgets.c) is a really-curious place for a seg-fault to be happening: that line is a Fortran-string copy that uses the Fortran trimmed string-lengths (and so should not be able to go out-of-bounds when fed proper Fortran CHARACTER strings). Is it possible that some of your strings have embedded ASCII-zeros or something like that, and are messing up the trimmed-length calculation?

Thank you very much Carlie! There is a blank line at the end of our file list. The problem was solved after we removed that line!

Try using the following command before running met4moves

stacksize limit unlimited