Time Stamp Issue to use MOZART output as CMAQ5.3 ICBC

CMAQ can use boundary conditions derived from global chemistry models (GCMs) like MOZART. I use mozart2camx to process mozart output and get CMAQ v5.3 IC, BC. However, CMAQ complains 1) IC is not time-dependent, and 2) BC has wrong time stamp. It is easy to fix the first issue by updating IC netcdf file TFLAG using NCO tool. For the 2nd, CMAQ requires hourly BC, but mozart2camx provides 6-hourly outputs only based on MOZART 6-hourly output time step. I wonder if anyone has the same issue or already has a fixation. I want to know how to update the processor or change CMAQ IC BC fortran codes to realize that CMAQ is able to read 6-hourly ICBC from MOZART successfully, otherwise.
For the MOZART processor for CAMx ICBC, please see http://www.camx.com/download/support-software.aspx.
THank you very much.
Fliu

Use M3Tools program m3interp thttps://www.cmascenter.org/ioapi/documentation/all_versions/html/M3CPLE.html to interpolate 6-hour BC’s into 1-hour BC’s.

IMNHO as the original systems architect for CMAQ, I feel that it is improper for the input time steps to be hard-coded the way you describe. The original would work perfectly well with virtually any mix of time steps and/or time independence for its input files (e.g., 17 minute TSTEP for METCRO3d, 23 minutes for METDOT3D, time independent IC, 99 minute BC)

Hi cjcoats,
Thank you for your response. Using m3tools may be a good idea. But I need to look at how.
IC file should be time-independent in CMAQ v5.3. Otherwise it crashes with the following error messages:
I updated the TFLAG and changed TIME STEP into 0 in the proper time point input IC file. It worked and the error message is gone.
But CAMQ could not automatically deal with 6-hourly BC files. We do need to convert 6-hourly into hourly.
It is easy to figure out what is wrong by comparing log files with those from CMAQ v5.3 benchemark run.
Error for non time-independent IC file:
>>—>> WARNING in subroutine RDTFLAG
Error reading netCDF time step flag for INIT_CONC_1
M3WARN: DTBUF 0:00:00 Jan. 1, 2014 (2014001:000000)

 >>--->> WARNING in subroutine XTRACT3
 Time step not available for file:  INIT_CONC_1
 M3WARN:  DTBUF 0:00:00   Jan. 1, 2014  (2014001:000000)


 *** ERROR ABORT in subroutine retrieve_time_de on PE 006
 Could not extract INIT_CONC_1                              file

Error message for BC file

File name “.//Inp/icbc_36km/bc.36km.cmaq.cb62r.20140101.ncf”
File type BNDARY3
Execution ID “???”
Grid name “MCIP_36km_CROSS”
Dimensions: 79 rows, 92 cols, 23 lays, 66 vbles, 1 cells thick
NetCDF ID: 655360 opened as READONLY
Starting date and time 2014001:000000 (0:00:00 Jan. 1, 2014)
Timestep 060000 (6:00:00 hh:mm:ss)
Maximum current record number 5

>>—>> WARNING in subroutine RDTFLAG
Error reading netCDF time step flag for INIT_CONC_1
M3WARN: DTBUF 0:00:00 Jan. 1, 2014 (2014001:000000)

 >>--->> WARNING in subroutine XTRACT3
 Time step not available for file:  INIT_CONC_1
 M3WARN:  DTBUF 0:00:00   Jan. 1, 2014  (2014001:000000)


 *** ERROR ABORT in subroutine retrieve_time_de on PE 110
 Could not extract INIT_CONC_1                              file

PM3EXIT: DTBUF 0:00:00 Jan. 1, 2014

Hi fliu,

  1. Regarding the ability of CMAQ to handle boundary condition files with time steps other than 1 hour, we have posted a code update here. This code update will also be included with the next minor CMAQ release.

  2. Regarding the issue your reported with your IC file, CMAQv5.3 can handle both time-dependent files (e.g. CGRID files written out at the end of each simulation day which are used as initial conditions / restart file for the next simulation day) and time-independent files (e.g. initial conditions created by ICON in “profile” mode). The error you were encountering likely points to a mismatch between the time stamp in your time-dependent file created by mozart2camx and the time stamp expected by your CMAQ simulation, i.e. the requested date and time of Jan. 1, 2014 0:00:00 (2014001:000000) is not present in that IC file.

Hogrefe.christian,
Thank you very much for the great updates. I replace the file with the new one according to the README - CMAQv5.3 Know Issues. But I get following errors when I recompile the CCTM. I have no idea and wonder if this code is still uncompleted. Thank you very much for taking the time to check.

_DATA_COPY -DSUBST_IN_SYN=SE_IN_SYN -Disam -DSUBST_PE_COMM="./PE_COMM.EXT" -DSUBST_CONST="./CONST.EXT" -DSUBST_FILES_ID="./FILES_CTM.EXT" -DSUBST_EMISPRM="./EMISPRM.EXT" -DSUBST_MPI="/samba/fliu/cmaq/CMAQ-master/lib/x86_64/pgi/mpi/include/mpif.h" ASX_DATA_MOD.F
PGF90-F-0004-Unable to open MODULE file centralized_io_module.mod (ASX_DATA_MOD.F: 86)
PGF90/x86-64 Linux 19.3-0: compilation aborted
make: *** [ASX_DATA_MOD.o] Error 2
ERROR while running make command

Christian Hogrefe,
I fixed the problem by re-downloading the code file. Now it works now. Thank you very much.