When I run ISAM , i want to set 32 isam_regions ,but when I set 32 regions,cctm can't export output,only update log,but when I set 18 isam_regions,cctm can normal operation.i want to set 32 regions normal operation.Please help me to solve this problem

this is my isam control fileisam_control_quanguo.txt (4.1 KB)
I use CMAQ5.4 CMAQ_Control_DESID.txt (13.8 KB)

It’s possible that your simulation is running out of memory. Are you running with the large version of IOAPI? See this release note for a brief description: What's New with the I/O API


I definitely agree with Ben’s response posted. You should compile IOAPI large version and use the IOAPI large to further compile CMAQv5.4. Then you will be ready to go.


thank you very much. I am running with IOAPI-Large and solve this problem. but I meet a new problem. i would be very grateful if you can help me.
isamlog.txt (30.6 KB)

Please review the CTM_LOG_* files to find the full error message.

grep -i error CTM_LOG*

Once you find the processor that has an error message in it, you may need to print out a few lines above to see what caused the error.

excerpt from the command manual:

man grep

-B num, --before-context=num
Print num lines of leading context before each match. See also the -A and -C options.

grep -B 10 -i error CTM_LOG*
1 Like