Could not read LUFRAC_01 from GRID_CRO_2D in CMAQv5.2.1

I am trying to run CMAQv5.2.1 with emissions input from 2016fh_16j and WRFv3.9.1.1 (processed by MCIPv5.1), and I get this abort error right in the beginning:

MCIPv5.1 gives LUFRAC_CRO output file with the variable LUFRAC variable in 40 layers (from NLCD40 land use of WRF), and the default runscript of CMAQv5.2.1 does not read in LUFRAC_CRO file. MCIPv5.1 does not provide the LUFRAC_01 variable in GRIDCRO2D file. Should I use an earlier MCIP version which does that - if so, which version of MCIP would output desired LUFRAC_01 variable?

@skunwar

MCIPv4.5 will provide the LUFRAC_xx fields in the GRIDCRO2D file. If you want to keep using MCIPv5.1, you can run your data through MCIPv4.5 for one time step to create the GRIDCRO2D file with all of the LUFRAC_xx fields that you need.

–Tanya

Worked perfectly - thanks for the trick!

Hi there,

I am having the same problem. I am running CMAQv5.3.2 and I get the same error regarding missing LUFRAC_XX fields. However, because my WRF fields are generated using WRF4.1.1, this workaround doesn’t work for me. MCIP4.3 or 4.5 do not support this WRF version. Is there any other option?

Also, why MCIP5 does not generate LUFRAC fields even though CMAQ requires them? is there any specific reason? (maybe CMAQ is transitioning towards not needing LUFRAC in the future?) Or are there any specific CMAQ settings that do not require LUFRAC_XX?

Thanks,

Marc

Hi all,

It turns out that I was using one sample run script (run_cctm_2010_4CALIF1.csh) that had the definition of the LUFRAC_CRO file commented out:

#setenv LUFRAC_CRO $METpath/LUFRAC_CRO_${YYYYMMDD}.nc

With this undefined, CMAQ was checking GRIDCRO2D for the LUFRAC_XX fields. Once I uncommented this out, and because I had the LUFRAC_CRO generated with MCIP5, CMAQ seems to be working.

Marc