Error of routine HLCONST

I add some reactions into cb6mp_ae6_aq mechanism and successfully install CCTM. But when i run my case, I encounter this error:
*** ERROR ABORT in subroutine HLCONST on PE 139
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@ not found in Henry’s Law Constant table in routine HLCONST.
And i don’t know how to fix it. I checked hlconst.F, found out there is a Henry’s Law Constant table but i don’t where the variables in this table come from. I thought the variables should be the same as in GC_cb6mp_ae6_aq.nml. But it turns out not. Does anyone know how to find out which Henry’s law constant is missing?

This doesn’t solve the problem, but gives a little information:
that strange string:
is a string of ASCII-zero characters. That looks like some name-variable is not being initialized…
The name in the error-message is CNAME, which comes into the routine as an argument. So the caller of HLCONST() is screwed up somehow

Thanks so much. It helps a lot.

Hi cjcoats,
I wonder if you know when i add new gas species what files should i change accordingly. It seems this error happens when i add new gas species into the model. When i add new gaseous reactions, I change the mech_mechansm.def file and GC_mechanism.nml.

Unfortunately, you need one of the chemists (not me) to answer that…

Oh OK. Thanks anyway

Hi, Lin-

Please check out the following from the CMAQ Frequent Questions page that describes how to add/modify chemical reactions:

I think this error message might point to a problem with your GC namelist file – specifically the entry for wet scavenging surrogate (WET-SCAV SURR). The value there needs to match a SUBNAME entry in hlconst.F. Can you post your new GC_mechanism.nml entries?


1 Like

Thanks so much for your help! Attached is my new GC namelist file.GC_cb6mp_ae6_aq.txt (28.6 KB)

In addition to aqueous chemistry and wet scavenging, HLCONST is also used in dry deposition calculations. I see there is a new dry deposition surrogate in your GC namelist (“VD_HGOS”). I believe this would at least require some updates to DEPVVARS and ASX_DATA_MOD. In ASX_DATA_MOD, the subname you use would need to match a SUBNAME in hlconst.F – could that be where the problem is?

Thanks for your help. I will check to see if this is the problem!



Signature is customized by Netease Mail Master

The problem has been solved through editing ASX_DATA_MOD.F. Thanks so much!

1 Like