How to set CMAQ/HDDM sensitivity input parameters for EMIS in specific REGIONS?

I am running CMAQv5.2 with HDDM successfully using the sensitivity input parameters (see attached
sensinput.dat.txt (759 Bytes) for domain wide.

Now I am going to run the CMAQ/HDDM focusing on sensitivity of only anthropogenic emissions (not all emissions including biogenic, wildfire, and lightning etc.) to NOx and VOC in specific 2 regions (I have developed region files in netcdf format used for CMAQ/ISAM successfully) such as 8-hour ozone nonattainment area and **entire county or state **. How should I set my sensitivity input parameters?

I developed a new sensitivity input parameter file (see attached
sensinput.dat.txt (769 Bytes)) according to " * The term ’ REGIONS’ (all-cap, one leading space). If this term is used, the next line must give an integer (2-leading spaces) number of regions to be defined. The following lines are used to specify regions from a regions netcdf file, and must exactly match the region name (2-leading spaces)." according to CMAQ-HDDM document at CMAQ/ at 5.2_DDM-3D · USEPA/CMAQ · GitHub. But it does NOT work.

It is really appreciated if you could provide an example of sensinput.dat according to my purpose because I did not find the sample on this anywhere.

Thank you so much for your time.

Here is an example of mixed emissions streams for CMAQ5.2 DDM. By the way, this stuff a lot more simple in the newly upcoming 5.4 version.


I can’t get the spacing to show up correctly on the forum, so follow the directions on that.


Hi Sergey,

Thank you so much for sharing the example. I will try accordingly.


One more question, can RGN1 and RGN2 overlay (e.g. RGN1 is covered by RGN2)?


You can create the ioapi file however you want, obviously. The DDM-3D model will read it and be ok with overlapping regions, because the first-order sensitivity parameters are independent of each other. The ISAM model will hopefully crash, because you are trying to have exact mass balance, and overlapping regions will possibly double count some emissions.


You said the first-order sensitivity parameters are independent of each other. How are the higher order parameters working on this?

I see the important difference between HDDM and ISAM (at least for the first-order sensitivity parameters so far). Thank you very much for the explanation.


Higher order sensitivities are dependent on the existence of correctly defined lower-order (first) sensitivities in the same control file.

Hi Sergey,

Thank you again for your reply.

When I use mixed emissions streams in EMIS and REGIONS for CMAQ5.2 HDDM, I developed the sensitivity input parameters ( (730 Bytes)
attached ) according to the example your provided.

I also have the following settings in my run script
setenv DDM3D_RGN Y # allows for a file specifying regions [ T | Y | F | N ] (default is N/F) set it below if Y/T
setenv REGIONS_1 /INPUTDIR/ # this is the same region file used for ISAM. The netcdf file includes RGN1 and RGN2. Is that correct?

In addition, I do not know if I need and how to set up the following environment parameters?

setenv DDM3D_BCRGN N # allows for a file specifying boundary regions [ T | Y | F | N ] (default is N/F) set it below if Y/T
setenv BCREGIONS_1


Hi Sergey,

I get the following error when I refer to your example of sensitivity input parameters above. The error indicates the model consider the term REGIONS as one of SPECIES. I am wondering if we put the term REGIONS in a wrong place.

 *** ERROR ABORT in subroutine SEN_NUM on PE 001         
 Sensitivity parameter REGIONS not found in species name array

PM3EXIT: date&time specified as 0

Thank you very much for taking the time to check.

Hi Sergey,

I figure it out that The term ’ REGIONS’ (all-cap, one leading space). I had 2 leading space.