Multi-day MCIP files for running onroad RPD

Hello,

I have one question about multi-day running for onroad RPD.
Based on the description in README files,
I set DAYS_PER_RUN=7,
I did not use MCIP to generate 7 days MCIP files,
I have daily MCIP files so I use nco command (ncks -d TSTEP,1,24) to cut the 2nd-7th days MCIP files and then combine (ncrcat) seven days MCIP files (169 hours) named them like METCRO2D_1707_08_14 (20170708-20170714)
then store them in …/mcip_7day/ and add setenv MET_ROOT_7day “…/mcip_7day/”, setenv MET_ROOT_3D_7day “…/mcip_7day/” in directory_definitions.csh.
The log file shows that it cannot find the METCRO2D files. I adjusted the multi-day MCIP files locations and their name, still did not work.
I am not sure the reason, do I have to use MCIP to generate multi-day files to for onroad RPD?

Thank you in advance!

That’s not the way to do it. From the I/O API Home Page:

The Models-3 I/O API is a programming interface, not a data format !!
I/O API files are not synonymous with “netCDF files” !!

Using netCDF operators is NOT SUPPORTED; instead you should use one of the M3Tools like m3cple for concatenating these files. These operators do not understand additional data structures embedded in these files, and do not do the job correctly.

And additionally, you seem to have other scripting-problems, that I will let someone else address…

Thanks a lot for correcting my mistake and providing these information!
I will try again.

In the mcip_7day directory, the 169-hour-long METCRO2D files you created need to have these filenames: METCRO2D_YYMMDD, where YYMMDD is the first day of the 7-day group. For example, the file that covers 7/8 through 7/14 should be “METCRO2D_170708”.

Also, the MET_ROOT doesn’t need to change to reference the _7day directory. If MET_ROOT is set to …./mcip/, then the scripts will automatically look for the 7-day files in …./mcip_7day/.

Creating 7-day MCIP files by way of m3tools is how we do it, via m3xtract.

image001.jpg

Thank you for these detailed information!

I tried to make a run script to use m3cple to combine METCRO2D_170701_00.nc (00:00-12:00) and METCRO2D_170701_13.nc (13:00-00:00) to be METCRO2D_170701 (25hours)
The main part of the script is
cp $MET_ROOT00/METCRO2D_20170701_00.nc $OUTDIR/METCRO2D_20170701.nc
setenv SYNCHFILE “NONE”
setenv METFILE1 $MET_ROOT13/METCRO2D_20170701_13.nc
setenv OUTFILE1 $OUTDIR/METCRO2D_20170701.nc
setenv GRIDDESC $MET_ROOT/GRIDDESC
m3cple N

but it showed an error:

Value for PROMPTFLAG: N returning FALSE
Returning default value TRUE for query:
“Continue with program?”

 Value for PROMPTFLAG:  N returning FALSE
 INFILE          :INFILE

 >>--->> WARNING in subroutine OPEN3
 File not available.

 Could not open file "INFILE".

 *** ERROR ABORT in subroutine M3CPLE
 Could not open file "INFILE".

I think I may make mistake to use m3cple. Could you please provide suggestion for this error?

Thank you.

NEVER run interactive programs with

setenv PROMPTFLAG NO

Otherwise, you’d have seen prompts such as:

Enter name for input data file [INFILE] >>

In any case, it should have been clear the program was trying to open INFILE not METFILE1… if you had not turned off the prompts, you would have been able to respond
with METFILE1 if you wished ;-(

I see, I just modified METFILE1 to INFILE, it works now.
Thank you for your help!