Cmaq nested error-species issue


#1

Dear All,

While trying to run CCTM for a nested domain, I encountered an error regarding species which I have never seen before. The strange thing is that I have run CCTM many times without any error for species defined. Please see these parts of the log file. I am awaiting your response.

The following GAS emission surrogate species are
not present from any of the Area, Point, Biogenic,
Marine Gas, or Lightning emissions sources
PACD AACD FACD GLYXL KET
ACET PRPA ETHY BENZ XYLMN
NAPH SOAALK

***ERROR:
One or more emission surrogates assigned to model species
are not found in emission sources.

Use one of the below options to continue.

  1. Change or remove the missing GC, NR and TR emissions surrogates from the
    namelists where they are defined OR if missing surrogates are for aerosol species,
    change or remove these surrogates from aerosol data table defined in AERO_DATA.F
    then recompile.
    or
  2. Change CTM_EMISCHK environment variable to False (F) in the runscript
    if model predictions are acceptable without using the above emissions.

ATTENTION: The following emission species are available
from the inputs but are not used: 35 Species
PNCOM ISPD ROOH MGLY
ACRYLONITRILE BENZENE BR2_C2_12 CARBONTET
CHCL3 CL2_C2_12 CL2_ME CL3_ETHE
CL4_ETHANE1122 CL4_ETHE CL_ETHE DICHLOROBENZENE
DICHLOROPROPENE ETOX HEXAMETHY_DIIS HFLUX
HYDRAZINE MAL_ANHYDRIDE MXYL NAPHTHALENE
NH3_FERT NVOL OXYL PROPDICHLORIDE
PXYL QUINOLINE TOL_DIIS TRIETHYLAMINE
UNK UNR XYL

 *** ERROR ABORT in subroutine EMIS_SPC_CHECK on PE 001  
 Species with the missing surrogates must have a surrogate found in at least one source.

PM3EXIT: DTBUF 0:00:00 June 1, 2012
Date and time 0:00:00 June 1, 2012 (2012153:000000)


#2

The way that emissions files are processed, as well as warnings and error messages, has changed for v5.3. The message is telling you that you have (via the EmissCtrl file) specified that certain species are emitted, but for which there are no emissions across any of the emissions streams you are using. Since you have CTM_EMISCHK set to T, this causes the model to abort. Possible ways to resolve the problem are listed. (We may need to modify this message to add that you can edit the EmissCtrl file.)

The other message informs you of the variables that are in your emissions input files, but which are not being used in the model.


#3

I thank you for your response sir. After I tried to set EMISCHEK to F, the CCTM stops at one point and does not go further. Same thing happens when I remove missing surrogates from GC namelist. I am looking forward to hearing from you. This is like when it stops:
65 Aerosol species with a grav. settling vel
1 ASO4J 5 VMASSJ
3 ANH4J 5 VMASSJ
5 ANO3J 5 VMASSJ

81 ASVOO1J 5 VMASSJ
82 ASVOO2J 5 VMASSJ
83 ASVOO3J 5 VMASSJ

CCTM freezes right here.


#4

First, have you been able to run the benchmark tutorial case? It would be good to make sure the problem is not with your hardware or MPI configuration. Also, you can then compare what “normal” log files look like to what you are getting, which may give you a hint where the problem is.

Another approach is to try simplifying the problem to isolate its cause. Turn off several runtime options, and see if you get any further.


#5

I thank you for your response sir. Yes, I have run the benchmark case one year ago, and I have run the model for several cases, so I do not think if there is something wrong with hardware.
I have not added lots of option to the model to look for the problem. I am just trying to run for nests. After I produced ICON and BCON using the bigger’s domain concentration files I encountered this. To mention again, CCTM just stops without any error after setting the EMISCHECK to F, so there is no actual log produced.
I am looking forward to hearing from you.


#6

Any further response is very much appreciated.


#7

What is the spatial scale of your simulation? Does the problem happen immediately, or after running for some number of hours or days?


#8

I thank you for your response sir. My domain has 35 columns and 25 rows with 2Km spacing in each direction (70 Km* 50 Km). I have preciously run this domain without any error, but this time I am trying with a nested domain. The parent domain was ran completely and ICON and BCON files are produced using the parent domain.
The problem happens immediately after checking the species, and it does not go further.
I am looking forward to hearing from you.


#9

If I am understanding you correctly, you have previously run this exact case (model version, domain, time period, emissions, and meteorology), using some other ICON/BCON files, and the simulation completed. Now, you are rerunning this same case, but instead using ICON/BCON files that you generated from a coarser simulation.

If that’s correct, then it seems pretty clear that the problem is with your new ICON/BCON files. When you say that “ICON and BCON files are produced using the parent domain,” how were they produced? Did you use the CMAQ ICON and BCON programs (this is the correct procedure), or did you attempt to create them yourself using netCDF or python tools (which is incorrect and is not supported)?

Assuming you have used the CMAQ ICON and BCON programs, please post your entire log file (not just the last few lines). Also, post the result of this command:

ncdump -h <BCONfile>

#11

Yes sir, you are understanding the issue in the right way. I have also used ICON and BCON programs for producing files. Please find the logs attached. I am sorry that I do not have access to BCON file until Saturday, I will post the BCON ncdump ASAP. I thank you for your time. I am looking forward to hearing from you.CTM_LOG_001.v52_intel_tehran5wp_20120601.txt (54.4 KB)
after removing missing surrogates.txt (55.0 KB)


#12

This is a small domain. Are you running on a single processor?
Your MODIS data is for a different time period than your simulation. I don’t think this is affecting you, but just to be sure, turn off windblown dust emissions. Also turn off gravitational settling.

setenv CTM_WB_DUST F
setenv CTM_GRAV_SETL F

Your model run appears to be hanging in VDIFF. This is before BCON files are even read. How long did you wait before killing the model?
Can you also post a log file from a simulation that worked, where you used some other ICON/BCON files?


#13

Hello. I killed the process after an hour when everything was still the same.After I tried setenv CTM_WB_DUST F and setenv CTM_GRAV_SETL F, the result was the same. Please find the log attached.
The volume of the log of successful run and BCON file is too big for uploading. May I email it to you?

CTM_LOG_001.v52_intel_tehran5wp_20120601.txt (52.2 KB)


#14

I should have been clearer when I said to post your entire log file! I meant that you should first create a minimum example that shows the problem. This is always good practice when seeking help on any internet forums.

In this case, what someone who is trying to help you needs is (1) the log file from the run that is hanging (at the start of the model run, before finishing the first time step), and (2) a log file from the “good” run. I do not need (or want!) to see a one-month log file. One day, one hour, or even one time step would be sufficient to see the difference between the good run and the one that is hanging.

You can just truncate the log file, or you can rerun, setting NSTEPS to 10000 (for one hour) to create a new, shorter log file.

The run that is hanging begins on June 1, 2015, while the long log file you sent begins on July 1, 2015. The MCIP data not only differ by date, but they are clearly from different runs of MCIP, as they have different numbers of variables in the files. To be sure that it is the different BCON files that is causing the difference, you need two runs that are the same in all other aspects.

Also, it is strange to me that your profile BCON file has more variables in it than the one that was derived from a simulation on a parent domain.


#15

I am sorry for such inconvenience, I will send you the log again, however I am sure the only difference is for ICON and BCON files. Just to make sure, the sent BCON file is produced from a simulation on a parent domain.

Sincerely,


#16

Hello,

When I tried with ICON BCON files based on a profile, I faced the same error regarding species. After that, when I set the EMISCHEK to False, there was no error and program ran successfully.
And finally, when I tried to run the program with ICON based on profile, and BCON based on the concentration file, the program ran successfully with EMISCHEK still turned off. Please find log files attached.
I am looking forward to hearing from you.
Sincerely,
iconbconprofile.txt (52.9 KB)
iconbconprofile-emischekfalse.txt (175.9 KB)
iconprofilw-bconm3conc.txt (1.2 MB)


#17

Do not setenv CTM_EMISCHK T. If you do, you are telling CMAQ to abort if some species are missing emissions. You do not have emissions for those species, so the program is (correctly) aborting. There is no need to run this case or post the log from this run again.

As I understand it, you have three runs beginning June 1:
(1) profile initial and boundary conditions
(2) profile IC, m3conc BC
(3) m3conc IC, m3conc BC

The first two work correctly, while the third does not. I can’t really tell what went wrong with the third. Perhaps try again, this time without changing the EmissCtrl file or any of the species namelists. Also, you might try rerunning ICON. If you have conducted a simulation on a parent domain, it is strange that you are missing so many species.

But also, if you are planning to run your simulation for months, then the initial condition simply does not matter. If you can’t get the m3conc-derived IC file to work, I would just go with the profile version. Having time-dependent boundary conditions is much more important. If that is working, then your simulation should be ok.