Error in run.cctm in WRF-CMAQ

Hi, I’m new to the CMAQ and am trying my best to run it. I received an error when executing cctm in CMAQ according to the following procedure. Can you please correct the error screen and script?

(1) geo_em/d01~4 and wrfout_d01~d04 calculated by WRF in the home/tmp/CMAQv5.1/data/wrf directory
The following is the design with domain 1 calculations
(ii) Run.mcip to process the meteorological data. (run.mcip is attached)
A file is created in Tmp/CMAQv5.1/data/mcip/d01
(iii) Run.icon to create the initial concentration field file. (run.icon is attached.)
A file is created in Tmp/CMAQv5.1/data/icon/d01
4) Run.bcon to create the boundary concentration field file (run.bcon is attached)
The file is created in Tmp/CMAQv5.1/data/bcon/d01
⑤ Run air quality simulation (run.cctm)
An error is displayed here. The error screen is attached. the file that should be output to Tmp/CMAQv5.1/data/cctm/d01 is not created.

The error message indicates that the METCRO3D file name or directory name is incorrectly specified in the run script.

Please use the ls or list command to verify that the file isn’t found.

ls -lrt /home/hiro/tmp/CMAQv5.1/data/mcip/d01/METCRO3D_110701

It may be that the file has an exension, that isn’t specified on lines 151-166
Or, the date isn’t specified correctly in EXTN

ls -lrt /home/hiro/tmp/CMAQv5.1/data/mcip/d01/METCRO3D*

If the path is correct for the METCRO3D file, then the above command will tell you what the filename is.

If the path is incorrect, then you may need to use the find command to determine the location of the METCRO3D file, to learn what the $METpath environment variable definition should be.

Thank you for your reply. I was able to fix it with the content you pointed out and re-performed CCTM and was able to solve the problem. thank you very much.
However, another error occurred again, is this error caused by not specifying the file name correctly?
I would like to know if there is any solution.
Thank you very much.

The error you obtained is similar.

CMAQ run scripts need to be modified to correctly specify the location and name of input files.

If you see the error message “File not available”, then you need to find the location of the input file, and then make edits to the run script to specify the correct path and filename.

In this case it is the INIT_GASC_1 environment variable that is specified incorrectly.

use the list command to verify that the file does not exist as it is currently defined.
ls -lrt /home/hiro/tmp/CMAQv5.4/data/icon/d01/CCTM_DS1a_Linux2_x86_64intel_CGRID.CMAQ51-BENCHMARK_20110630

Check to see if any files exist in the directory that is specified:
ls -lrt /home/hiro/tmp/CMAQv5.4/data/icon/d01/*

Edit the run script to specify INIT_GASC_1 environment variable.

That environment variable may be defined in more than one place, so you will need to follow the logic of the c-shell script to determine where to make the edit.

You can also add debug options to the run script. (add -v or -x to the top of the script)
Do a google search for more information about these options.

The following shell script starts with:

Change the line to:
#!/bin/csh -x

Thank you so much for your response.
Similarly, I was able to solve it by specifying the file path and name correctly. However, I got another error again. This time I got an error like the image below. Looking back at past questions, it was written that it would be good to correct the settings for CTM_STDATE, CTM_STTIME, CTM_RUNLEN, and CTM_TSTEP, but I entered STDATE = 20150721, STTIME = 000000, NSTEPS = 240000, TSTEP = 010000 and there is no problem It seems like
I’m sorry to ask this question again and again, but could you please enlighten me?