Making JTABLE for domains outside the US

Hellow to everyone,

Can somebody guide me in the process of making JTABLES for CMAQv4.7.1? Currently, I’m trying to make a run whit a domain located in South America. How can I make the JTABLE files for two months of simulation in this domain? Where can I found the input information for JPROC and in which format do I have to format it?

Sorry if it’s too much a noob question but in the users guide I did not found examples on how to use JPROC to generate these files.

Thank you!

There should be bldit.jproc and run.jproc scripts in the tarball that you downloaded. It might have been in a separate tarball from the main code. JPROC needs files such as ETirradiance.dat and PROFILES.dat, which should be in the raw/phot directory.

Thank you for answering!

Unfortunately, there are no .dat files in the phot directory for v4.7.1 in the repository. Y found two .dat files (OMI_1979_to_2019.dat and PHOT_OPTICS.dat) in v5.3 phot/inline repository. These are the equivalent of those you mentioned?

The input and output data are not in the repository. Instead you need to download the data files.
Go to
Download → Software
Log in.
Select CMAQ from the drop-down menu on the right hand side of the screen.
Make selections from the drop-down menu to select the version you want.
Toward the bottom of the screen, follow the links to download CMAQ scripts (includes bldit.jproc and run.jproc) and CMAQ default data files (which includes data/raw/phot directory).

Thank you so much, I found the raw/phot folder.

But now, when I run Jproc (aready compiled it), it appears this error in every day of the run:

*** ERROR ABORT in subroutine READCSQY
Could not open NO2_SAPRC99 data file

I don’t think that the problem is in the file path of the data, because it passes all the checks if the run script and the program can read the ETirradiance.dat , which is in the same folder:

…Opening File on UNIT 99

…Data for 131 wavelengths read from file

Any thoungts on what this error coul be?


I don’t know what the error could be. I might be able to tell if you showed more of the log file. As you correctly note, the NO2_SAPRC99 data file is in the same directory as ETirradiance.dat, so unless you changed the run script the program should be able to find it. The file is a plain text file, so verify you can view its contents and it has not become corrupted.

The original documentation for the JPROC photolysis preprocessor is here. As stated in section 14.2, clear-sky photolysis rates are calculated for latitude bands ranging from 10 degrees N to 60 degrees N. Obviously, this would not be satisfactory for a domain in the southern hemisphere. You may need to modify the code to specify the latitude range desired.

I hope this helps. The tabulated photolysis rates was replaced by the online photolysis module in CMAQ v4.7, released in December 2008. We can’t provide a great deal of support for it in 2021.

I checked the NO2_SAPRC99 fiel and it opens normally, allso the constenst seem fine, lika. atable of values. I also tryed to download again the files, but the outcome is the same. This is the complete file log of the run, but it basically repeats the same error for all the days of the run.

jprog.txt (54.1 KB)

I understad that this a very old version and appreciate a lot all your help.

I just recompiled it and verified that the program works for me. Also, it outputs J values for all latitudes, so it should work fine for the southern hemisphere.

I suggest editing readcsqy.F. Prior to the open statement on line 120, insert a line telling the program to print the value of CQFILE:


It should be the full path. It is finding the full path to ETirradiance.dat, but not for NO2_SAPRC99. If you figure out why, that should allow you to resolve the problem.

I recompiled JPROC, runed it whith actualized library pahts and now it runs fine.

Thank you for all your help!!!