Question about run CMAQ 5.0

Dear all,

I have compile CMAQ v. 5.0 on Linux machine x86_64 with


source /opt/intel/compilers_and_libraries_2020.1.217/linux/bin/compilervars.csh intel64
source /opt/intel/compilers_and_libraries_2020.1.217/linux/mpi/intel64/bin/mpivars.csh release

I am not a sysadmin. I have experiment with other version of CMAQ and also compiled and run CMAQ 5.0 but compiled and run it on other machines without problem for example with /intel/Compiler/11.1/072/

But now I compile CMAQ v. 5.0 without any error on ths new INTEL but when I run bcon, icon and cctm I don’t succeed to run a test case. With jproc and MCIP I haven’t problem.

For example when I run bcon I received the following error:

Input data path, M3DATA set to /home/dsyrakov/M3HOME/data

Sat Oct 31 15:07:23 EET 2020
cat: /home/dsyrakov/M3HOME/work/bcon/cfg.CMAQ-BENCHMARK: No such file or directory

setenv GRIDDESC /home/dsyrakov/M3HOME/work/GRIDDESC
setenv IOAPI_ISPH 19
setenv LAYER_FILE /home/dsyrakov/M3HOME/data/mcip/METCRO3D_Benchmark
setenv gc_matrix.nml /home/dsyrakov/M3HOME/work/bcon/BLD_V5f/GC_cb05tucl_ae6_aq.nml
setenv: Variable name must contain alphanumeric characters.

The same error i received when run icon and cctm.

I hope someone can help me overcome this mistake. Thank you in advance



This is a script-error of some sort (setenv is a script-command, not a modeling command). Perhaps you might put

set echo

at the start of these scripts, and would then get more diagnostic info, that might be used to find the problem.

Dear Carlie,

Many thanks for your fast reply. I put set echo

at the start of these scripts, but I haven’t get more diagnostic info and I don`t find the problem. By the way I run these run file of CMAQ 5.0 on the other machine with Intel intel/Compiler/11.1/ and all is OK.

I think that there is a problem with this version of Intel compilers_and_libraries_2020.1.217.

Best regards,


CMAQv5.0 was released in February 2012. Why are you using such an old version?

I believe the issue you are running into was addressed in CMAQv5.0.1, released July 2012. The name of the environment variables contained embedded periods, which causes problems on some Linux variants. The names were changed to use underscores.

See “NML & runscripts” section here.

Dear Chris Nolte,

Thank you very much for your help. I only had time yesterday
to compile and run the test case of CMAQ v. 5.0.1. All is OK now with this
version. It’s good that I had it downloaded when it came out in 2012, but
I also had experience with v 5.0 on the old version of Intel.

It’s nice to use newer versions, but we’re only two people, without a
system administrator, and we have to run WRF and CMAQ quickly operatevly.

I want to thank you once again.

Best regards,